আপাচে শুরু হচ্ছে না


9

তাই আমি নিম্নলিখিত কমান্ড দিয়ে আমার অ্যাপাচি 2 সার্ভারটি শুরু করার চেষ্টা করেছি ...

sudo service apache2 start

তবে আমি এই ত্রুটি বার্তাটি পেয়েছি ...

Job for apache2.service failed. See "systemctl status apache2.service" and "journalctl -xe" for details.

সুতরাং যখন আমি সিস্টেমটিটিএল চেষ্টা করে দেখি, তখন আমি এটি পাই ...

● apache2.service - LSB: Apache2 web server
   Loaded: loaded (/etc/init.d/apache2)
   Active: failed (Result: exit-code) since Mon 2015-07-06 10:34:49 IST; 4min 23s ago
     Docs: man:systemd-sysv-generator(8)
  Process: 8899 ExecStart=/etc/init.d/apache2 start (code=exited, status=2)

Jul 06 10:34:49 archisman-HP-ProBook-440-G2 systemd[1]: Starting LSB: Apache2 web server...
Jul 06 10:34:49 archisman-HP-ProBook-440-G2 apache2[8899]: /etc/init.d/apache2: 64: .: Can't open /etc/apache2/envvars
Jul 06 10:34:49 archisman-HP-ProBook-440-G2 apache2[8899]: /etc/init.d/apache2: 76: .: Can't open /etc/apache2/envvars
Jul 06 10:34:49 archisman-HP-ProBook-440-G2 apache2[8899]: ERROR: APACHE_PID_FILE needs to be defined in /etc/apache2/envvars
Jul 06 10:34:49 archisman-HP-ProBook-440-G2 systemd[1]: apache2.service: control process exited, code=exited status=2
Jul 06 10:34:49 archisman-HP-ProBook-440-G2 systemd[1]: Failed to start LSB: Apache2 web server.
Jul 06 10:34:49 archisman-HP-ProBook-440-G2 systemd[1]: Unit apache2.service entered failed state.
Jul 06 10:34:49 archisman-HP-ProBook-440-G2 systemd[1]: apache2.service failed.

http: // লোকালহোস্ট / আমার ব্রাউজারেও আমাকে একটি ত্রুটি দেয় যার অর্থ অ্যাপাচি চলছে না।

আমি যখন এটি করি ...

sudo restart apache2

আমি এই ত্রুটি পেয়েছি ...

restart: Unable to connect to Upstart: Failed to connect to socket /com/ubuntu/upstart: Connection refused

কেউ দয়া করে সাহায্য করুন।



যদি আপনার apache2.conf এর মতো কনফিগারেশন ফাইলগুলিতে ত্রুটি থাকে তবে এটি ঘটতে পারে ...
— সুদীপ ভান্ডারী

উত্তর:


4

আমি মনে করি কোন কারণে আপনি এনভ্যাভার্স কনফিগারেশন ফাইলটি মুছে ফেলেছেন

Jul 06 10:34:49 archisman-HP-ProBook-440-G2 apache2[8899]: /etc/init.d/apache2: 64: .: Can't open /etc/apache2/envvars
Jul 06 10:34:49 archisman-HP-ProBook-440-G2 apache2[8899]: /etc/init.d/apache2: 76: .: Can't open /etc/apache2/envvars

সুতরাং আপনাকে এটিকে তৈরি করতে হবে এবং এখান থেকে সামগ্রীটি আটকে দিতে হবে (এই ফাইলটির জন্য ডিফল্ট সামগ্রী)

sudo touch /etc/apache2/envvars
sudo nano /etc/apache2/envvars

তারপরে যথারীতি অ্যাপাচি পরিষেবা পুনরায় চালু করুন

sudo service apache2 restart

1

আমার একই সমস্যা ছিল, আমি apache.conf fileকিছু কারণে পরিবর্তন করেছি , যা আমাকে আপনার মতো একই ত্রুটির দিকে নিয়ে যায়।

আমি অ্যাপাচি সার্ভারটি পুনরায় ইনস্টল করেছি, এখন সবকিছু ঠিকঠাক চলছে।

নিম্নলিখিত আদেশগুলি ব্যবহার করুন:

  1. অ্যাপাচি আনইনস্টল করুন:

    sudo apt-get remove apache2*
    
  2. অ্যাপাচি ইনস্টল করুন

    sudo apt-get install apache2
    
  3. সার্ভার পুনরায় চালু করুন

    sudo service apache2 restart
    

@ আরনাউদবি: আপনি দয়া করে আমার সম্পাদনাগুলি পর্যালোচনা করতে পারেন এবং ভবিষ্যতে আপনার নিজস্ব সম্পাদনাগুলি উন্নত করতে সম্পাদনা
— সহায়তাও

1
লগ ফাইল চেক না করে সরাসরি কাউকে অ্যাপাচি 2 সরানোর এবং পুনরায় ইনস্টল করার পরামর্শ দিলে কারও কাছে বিশাল ডেটা ক্ষতি হতে পারে।
— রিপন
আমাদের সাইট ব্যবহার করে, আপনি স্বীকার করেছেন যে আপনি আমাদের কুকি নীতি এবং গোপনীয়তা নীতিটি পড়েছেন এবং বুঝতে পেরেছেন ।
Licensed under cc by-sa 3.0 with attribution required.